uberAgent Support

No Data in Splunk Even Though uberAgent Sends Successfully

Symptoms

You configured uberAgent to send data directly to Splunk without a locally installed Universal Forwarder.

According to uberAgent's log file there are no events in its in-memory send queue, indicating a successful data transfer to the Splunk server(s):

ReceiverStatistics,Splunk; SPLUNKSERVER:19500 - Events in queue: 0, queue size: 0.0 KB, sent: 1597, added to queue: 1597, rejected from queue: 0

When searching Splunk's internal logs for errors using the following search:

index=_internal error

you see messages like the following:

ERROR TcpInputProc - Message rejected. Received unexpected 707406419 byte message! from src=IPADDRESS:PORT. Maximum message allowed: 67108864

Cause

The port uberAgent sends data to (default: 19500) is configured to receive data from Universal Forwarders.

Splunk Universal Forwarders do not send raw event data, they use a specific protocol. uberAgent, on the other hand, sends raw event data. If the formats sent by the source and expected on the target do not match above error message may be logged and the incoming data is ignored on the Splunk server.

Resolution

Communication: uberAgent directly to Splunk

If uberAgent is sending data directly to Splunk do not open port 19500 via Forwarding and receiving on the Splunk server. Install the uberAgent_indexer app instead which opens port 19500 as a raw TCP port.

Communication: uberAgent to Universal Forwarder to Splunk

If uberAgent is sending data to Splunk via a locally installed Universal Forwarder open TCP port 19500 on the Universal Forwarder (the same machine uberAgent runs on) and configure uberAgent to send to localhost:19500 as described here.

To enable Splunk to receive the Universal Forwarder's data open a receiving Port on Splunk as described here.

 

 

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