0

VPN interace not detected

I'm trying to monitor the VPN interfaces on a laptop with Uberagent 6.0 installed via the Splunk UMX app. The Machine Network configuration shows the Ethernet and the Wireless interfaces on the laptop but the VPN interfaces are not shown. I have seen this demonstrated so I know it's supported. I've just installed UA out of the box and have only configured the Splunk receiver. I also tried UA 5.3.1 with the same result. I can clearly see the VPN interfaces if I run ipconfig/all on the laptop which is running Windows 10. What could be the problem?

4 comments

  • Avatar
    Dominik Britz Official comment

    Hi John,

    uberAgent ignores adapters without a gateway unless the adapter type is VPN.

    Cisco's AnyConnect VPN adapter, and others, identifies itself to the OS not as a VPN but as an Ethernet adapter. Therefore, it is ignored.

    There will be an option in the upcoming beta 2 of uberAgent 6 to include all adapters.

  • 0
    Avatar
    John Perrin

    Hi Dominik, 

    Thank you. It was quite mysterious so good to know it's not a config issue. The VPN connections are shown as Ethernet adapters so your explanation makes sense. An option to include all adapters would help. Do you know if the description of the Ethernet adapter will be sent to Splunk? The description field identifies it as a VPN connection which would be very useful if available. Otherwise we will need to infer VPN connections from the IP4V address which would not be 100% reliable.

    When will beta 2 be available for testing?

    Regards,

    John  

  • 0
    Avatar
    Dominik Britz

    The description is sent in the field NetworkConfigDescription.

    Source: https://uberagent.com/docs/uberagent/latest/metrics/machine/inventory/#network-configuration-information

  • 0
    Avatar
    John Perrin

    Thanks. Much appreciated

Please sign in to leave a comment.